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Outline3D Basics 

Outline3D Basics 
Introduction  
 
Outline3D is the flexible 3D design tool that enables furniture suppliers, interior designers and real estate 
firms to present a complete product range to clients in the most visual way. Potential customers can walk 
through virtual 3D interiors/exteriors created in Outline3D, examine them from any point of view and make 
more informed buying decisions. 

Outline3D benefits:  

• Real estate firms: showcase apartments or offices that have yet to be built.  
• Furniture suppliers: demonstrate the most suitable furniture, wallpaper and coverings combinations.  
• Designers: create interior designs and easily deliver them to local and remote clients.  

Outline3D can help you speed up the exchange of ideas with clients, improving design times and 
guaranteeing greater customer satisfaction!  

Key features of Outline3D (Offline)  

With Outline3D you can:  

• Draw any kind of 2D interior and generate a 3D model from it by a mouse click. To speed up the 
process, use your 2D plan (GIF, BMP, or JPG) as a background.  

• Add furniture, finishings and fittings from a comprehensive Outline3D catalog. You also can use 
your own models stored on your local PC: 3D (VRML) files for the furniture items and 2D files (GIF, 
JPG, PNG) for finishing materials.  

• Print the 3D interior specification, which includes detailed 2D plan and a complete list of the 
furniture items and finishing materials.  

• Save and print a 2D projection of the 3D interior (supported files formats include JPG, BMP and 
PNG).  

• Export created interior into VRML format and publish it on your Web site. Then it can be viewed by 
any standard VRML browser such as Cortona (R) VRML Client from ParallelGraphics.  

Outline3D also offers you an online version that can be integrated in your own Web site. That allows you to 
establish an online design service for remote clients.  

For more information, please visit http://www.outline3d.com.  

Quick Tour  

This quick tour contains a brief description of the Outline3D functionality.  

Step 1. Open an existing 3D scene or create a new scene.  

Opening existing 3D scenes:  

1. Click the button on the Main toolbar at the top of the Outline3D window. The 
Load Your Scene window appears.  

2. Choose a file from the list of available files in *.o3d format.  
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3. Click the Open button.  

Creating 3D scenes:  

You can create 2D contours of rooms using Plan Editor. To open the Plan Editor window from the Outline 

3D window, click the button on the Main toolbar. Here you can specify the layout of walls, their 
thickness, the ceiling height, and also place doorways, and window openings.  

When your 2D contour is complete, click the button on the Tool bar of the Plan Editor window. 
This will make a 3D scene on the basis of the current contour and open it in the Outline3D window.  

Step 2. Navigation in the 3D scene.  

You can navigate in 3D scenes, displayed in the 3D View window by using the keyboard, or the mouse, or 
the interface elements of the View panel. The View panel is located at the bottom of the Outline3D window.  

You also can navigate with the help of the 2D Plan window that displays the viewer position, orientation, 
field of view, and contains a slider, that allows you to zoom. 

 

Step 3. Adding furniture items and other 3D objects to the 3D scene.  

To add furniture and other objects to the current 3D scene, choose a 3D object in the Outline3D Resource 
galleries, then drag and drop its icon into the 3D scene to the desired place.  

 

Step 4. Manipulate objects in the 3D scene.  

The key operations involving objects are moving, rotating, scaling and deleting objects. To enter the Edit 
mode, double-click an object in the 3D View window. White borders appear around the object.  
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The Object panel appears below the 3D View window.  

 

Step 5. Getting specification.  

You can get a detailed specification of the 3D objects used in your 3D scene by clicking the button on 
the Main toolbar of the Outline3D window.  

Step 6. Saving 3D scenes.  

1. Click the button on the Main toolbar at the top of the Outline3D window. The 
Save Your Scene window appears.  

2. Enter the file name.  
3. Click the Save button.  

 

Getting Help in Outline3D  

In Outline3D, you can get help without interrupting your work.  

To open the Help file:  

• Click the button on the Main toolbar when working in the Outline3D window, or  
• Choose the Help Contents item from the Help menu when working in the Plan Editor window.  

For getting description of a toolbar button or other control element, position the mouse pointer over this 
control element. The name of the element will appear below it in the tooltip string.  

For product support, you can send an e-mail to support@outline3d.com Before posting your message, 
please check the online Help service. Include in your message any information that could help better 
answer your question or make solving the problem easier:  

• The error messages generated by the program.  
• The description of the unexpected behavior of the program.  
• Document the computer configuration: processor, RAM, graphics card, etc.  
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• Software: OS version and Internet browser used (including their versions from the About dialog 
boxes).  

Ordering Information  

Limitations in the trial version  

The trial version has the following limitations:  

- The Save and Publish functions are disabled. You cannot save created interiors or export them into VRML 
format.  

Note: You can examine these functions by using the online version of Outline3D that is available at 
http://www.outline3d.com. To access these functions, you will need to register as professional user (the 
professional registration is free within 30 days).  

How to order Outline3D:  

You can order Outline3D (Offline) from the online software shops or directly from ParallelGraphics and its 
local distributors.  

You can find more information about ordering Outline3D at: http://www.outline3d.com/order  

If you have any questions, please contact us at sales@outline3D.com  

To register the trial version of the Outline3D (Offline):  

1. Launch the Outline3D Offline program.  

2. Click the button on the main toolbar of the Outline3D window. The Register Outline3D 
(Offline) dialog window will appear:  

 

3. Enter your registration data into the form, and click the OK button.  
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The Plan Editor Window 
Working in the Plan Editor Window 

In the Plan Editor window you can create two-dimensional contours of rooms by building walls, setting 
doorways and window openings. When a contour is complete, you can make a 3D scene on its basis and 
open it in the Outline3D window.  

To start working in Plan Editor:  

Activate the Plan Editor window. If it is not instantiated yet, press the button on the Tool bar at the top 
of the Outline3D window. If it is already active, you can clear the previous contents of the Plan window and 
start creating a new contour of rooms.  

To create a new contour of rooms:  

• Choose the New item from the File menu, or  

• Click the button on the Tool bar.  

When you work in Plan Editor, you are always in one of six available design modes: Building Walls, 
Moving Walls, Changing Walls, Change Room Size, Setting Doorways, and Setting Window 
Openings design modes.  

To select the desired design mode:  

• Choose an item with the corresponding name from the Edit menu, or  
• Click the corresponding button on the Mode bar.  

Following three design modes are normally activated when you create the contour of rooms:  

1. In the Building walls design mode you build the walls and partitions of your rooms.  
2. In the Setting doorways design mode you specify the position of doorways, and set their sizes, if 

they are different from the default values.  
3. In the Setting window openings design mode specify the position of window openings, and set 

their sizes, if they are different from the default values.  

Once you have created the contour of your rooms in the Plan window, you can modify their contour in three 
remaining design modes:  

1. In the Moving walls design mode you change the position of the walls of your contour.  
2. In the Changing walls design mode you set the thickness of walls, delete walls, or mark walls as 

main walls.  
3. In the Change room size design mode you modify the size of rooms.  

When you create and edit the contour of your rooms in the Plan window, you can undo and redo your last 
action.  
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To undo/redo your last action in the Plan Editor window:  

• Choose the Undo/Redo item from the Edit menu, or  
• Click the Undo/Redo button on the Tool bar.  

As soon as you have created your contour of rooms or decided to retain its current version, you can save it 
on your computer for further use. Later you can open this contour in the Plan window.  

When you have finally completed creating the 2D contour of rooms, make a 3D scene on its basis. The 
created 3D scene will be opened in the Outline3D window.  

To simplify your work in the Plan Editor window:  

The Plan Editor window simplifies the task of creating and editing 2D contours. Prior to creating your 
contour, specify the size of the Workspace, and default values for wall thickness, ceiling height, size of 
doorways and window openings using the Options menu. 
You can also customize the appearance of the Plan window to simplify working with the contour of your 
rooms. In the Plan window you can:  

• Show and hide various bars of the Plan Editor window.  
• Make visible or hide the Point grid, and change its spacing.  
• Show the Background image with the outline of rooms.  
• Specify the size of control points displayed in the Plan window.  
• Gradually or stepwise magnify the plan and scroll in it.  

Navigation in Plan Editor  

You can zoom in and out, when working in the Plan Editor window. The zoom panel is situated on the right 
side of the Plan Editor window.  

• Click the "+" button on the zoom panel, to zoom in  
• Click the "-" button on the zoom panel, to zoom out  

When the contours of your rooms do not fit to the workspace size, slider thumbs appear on the navigation 
bars of the Plan Editor window. Drag these thumbs to move up or down and left or right the contour. 

Note. You can also zoom, and pan with the use of the mouse wheel. Rotate the mouse wheel, to zoom the 
plan. Move the mouse with the wheel pressed, to pan the plan.  

Menus and Toolbars  

The Plan Editor window contains a menu and four toolbars, which enable you to perform various actions 
with the 2D contour of rooms, which is displayed in the Plan window. The Plan Editor Menu is located along 
the top of the Plan Editor window and permanently shown. The Tool bar is positioned above the Plan 
window, the Mode bar is placed to the left from the Plan window. Navigation bars consists of two bars which 
frame the Plan window from the right and bottom. The Status bar is shown at the bottom of the Plan Editor 
window. The user may hide or show the toolbars of the Plan Editor window.  

The tables below describe actions performed when the user chooses the items from the Plan Editor sub-
menus. If the same actions are activated by clicking buttons on toolbars, they are indicated in the third and 
fourth columns of the tables respectively.  

 8 



The Plan Editor Window 

File 
Allows you to accomplish file operations in Plan Editor and create 3D scenes. 
 
New a new empty plan of rooms in the Plan window. 
Open Opens a contour of rooms which has been saved before in a file. 
Save Saves the current contour of rooms in a file with the current file name and 

location. 
Save As... Invokes a dialog window, where you can specify the file name and location 

for a file, where the current contour of rooms will be saved. 
Set Background 
Image... 

Loads a new Background image and displays it on the Workspace. 
Supported file formats are: GIF, JPG and BMP. 

Make 3D scene Makes a 3D model of rooms on the basis of the current contour of rooms, 
opens it in 3D scene in the 3D View window, and transfers the focus to this 
window. 

 
Edit 
Lets you undo the previous action, select current design modes in Plan Editor, scale and optimize the 
current contour of rooms. 
 
Undo/Redo Undoes/redoes the last user's action. 
Building walls Enters the Building walls design mode. In this mode, you can build new 

walls by adding control points to the plan. 
Moving walls Enters the Moving walls design mode. In this mode you can move walls and 

control points of the current contour of rooms using the mouse. 
Changing walls Enters the Changing walls design mode. In this mode, you can change the 

thickness of walls, delete walls, or assign them as Main walls. 
Changing room 
sizes 

Enters the Changing room sizes design mode. In this mode you can set the 
length, width and height of rooms, resize all rooms proportionally to the 
chosen room, and get information about rooms. 

Setting doorways Enters the Setting doorways design mode. In this mode, you can specify the 
position, height and width of doorways at the contour of rooms. 

Setting window 
openings 

Enters the Setting window openings designing mode. In this mode, you can 
specify the position, height, width and the sill's level of window openings. 

Scale Resizes all the walls of the rooms. You can specify the factors of 
magnification in X and Y directions. 

Optimize Clears unnecessary control points from the current contour of rooms. 
 
View 
Allows to show or hide toolbars in the Plan Editor window, customize the appearance of the Workspace, 
and fit the Workspace to the contour. 
Tool bar Allows to show or hide the Tool bar, which contains buttons triggering the 

frequently used commands in the Plan Editor window. 
Mode bar Allows to show or hide the Mode bar, which contains buttons for selecting 

the current design mode in the Plan Editor window. 
Status bar Allows to show or hide the Status bar, which display edit boxes and buttons 

specific for different design modes in the Plan Editor window. 
Navigation bars Allows to display or hide the Navigation bars, which allows you to zoom and 

scroll in the Plan window. Scrolling is enabled when the Workspace cannot 
be entirely shown in the Plan window. To invoke the Workspace size dialog 
window click the box on the bottom bar. 

Background 
image 

Allows to display or hide the Background image, which is stretched to fit the 
Workspace. A check mark indicates that the Background Image is visible on 
the Workspace. 

Point grid Allows to display or hide the Point grid on the Workspace. A check mark 
indicates that the Point grid is visible on the Workspace. 
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Snap to grid Enables Snap to grid feature that forces the new control points being added 
to the contour to snap only into the grid intersections on the Workspace. A 
check mark indicates that the Snap to grid feature is activated. 

Fit to contour Fits the Workspace to the size of the current contour of the rooms and 
adjust zoom to the size of the Plan window. 

 
Options 
Enables you to specify the appearance of the Plan Editor window and the Workspace. 
 
Control point size Allows you to specify the size of control points displayed on the Workspace. 
Grid Spacing Allows you to set the spacing between grid points. 
Workspace size Allows you to set the size of the Workspace, and scale the current contour 

of rooms. 
Defaults Allows you to change the default sizes of rooms, doorways and window 

openings. 
 
Help 
 
Help Contents Displays the Outline3D Help system. 
About Displays the Plan Editor copyright and its version number. 

 

Using Background Image  

The Background image in Plan Editor is a graphic image, which can be displayed on the Workspace. This 
image is automatically scaled in the Plan window to fit the current size of the Workspace. If the plan of 
rooms that you want to build, is available in GIF, JPG or BMP graphic formats, you can use it as the 
Background image. It will help you to create and modify the contour of rooms in Plan Editor.  

To set a Background image:  

1. Choose the Set background image item from the File menu, or click the button on the Tool 
bar.  

2. In the Set Background Image dialog window choose the desired file and click the OK button.  

Once you have set the Background image in the current Plan Editor session, you can switch it on or off 
depending on your current needs.  

To display the Background image:  

1. Choose the Background image item from the View menu, or  

2. Click the button on the Tool bar.  

To hide the Background image:  

• Choose the Background image item from the View menu, or  

• Click the button on the Tool bar.  
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Opening and Saving Contours  

Using Plan Editor you can save your contours of rooms and open them later for further use. Plan Editor 
saves and opens contours in its own proprietary format ( *.ctr file extension).  

To open an existing contour of rooms in the Plan Editor window:  

• Choose the Open item from the File menu, or  

• Click the button on the Tool bar at the top of the Plan Editor window.  

This will invoke the Open contour dialog window. In this window select the drive, the folder, and the file you 
want to open. Click the Open button to open the chosen file in the Plan window.  

To save the current contour of rooms in a file with a different name or location:  

• Choose the Save as item from the File menu.  

In the Save contour dialog window select the drive and folder, where you want to save your file, specify its 
name in the File name edit box and click the Save button.  

To save the current contour of rooms to a file with current file name and location:  

• Choose the Save item from the File menu, or  

• Click the button on the Tool bar at the top of the Plan Editor window.  

This will save the current contour of rooms to a file with the current name and location only if you have 
already saved it with this name during the current Plan Editor session. Otherwise the Save contour dialog 
window will be invoked.  

Building Walls  

Building walls is the most important stage in the process of creating the contour of rooms in Plan Editor. 
When you build walls, you determine the position of external and internal walls of rooms, the number of 
rooms and their shape.  

In Plan Editor you can add new walls to the contour of rooms in the Building walls design mode. In this 
mode, you use mouse to set control points that symbolize the ends of linear wall sections. By setting control 
points, you create wall sections; a number of wall sections constitutes contour of rooms.  

To enter the Building walls design mode:  

• Choose the Building walls item from the Edit menu, or  

• Click the button on the Mode bar.  

To create the first wall section of the contour:  
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1. Click the Workspace at the point, where you want the first wall section to start from. The position of 

the first control point will be shown by the square.  

2. Move the mouse pointer over the Workspace, the square will follow the mouse pointer, and a 
thin black line will be drawn connecting this square with the first control point, helping you to choose 
a place for the second control point. The distance between two squares, which is the current length 
of the wall section you build, will be displayed near the line.  

3. Click again when the square is over the place where you want to set the second control point. 

The second control point will be shown on the Workspace by the square, and the line 
connecting two control points will become thick.  

To add a new wall section to the contour of rooms:  

1. Position the mouse pointer over an existing wall, where you want to start a new wall section. A 
square appears and follows the mouse pointer along the wall helping you to choose the place for 
the first control point of the new wall section.  

2. Click to set the first control point and start building the new wall section, the square changes to .  

Note: If you click one of existing control points at the contour of rooms, this control point will change 
its color to red and the next wall section will start from it.  

3. Move the mouse pointer over the Workspace, the square will follow the mouse pointer, and a 
thin black line will be drawn connecting this square with the first control point, helping you to choose 
a place for the second control point.  

4. Click again when the square is over the place where you want to set the second control point of 

the new wall section. The second control point will be shown on the Workspace by the square, 
and the line connecting two control points will become thick.  

Repeat this process until you build all walls of your contour.  

To stop adding new wall sections to the contour:  

• Click any of existing control points, or  
• Press the Esc key on the keyboard.  

To clear the Plan window and begin creating a new contour:  

• Choose the New item from the File menu, or  

• Click the button on the Tool bar.  

Notes:  

1. By default, the angle between intersecting walls is 90 degrees, it means that normally you can build 
horizontal and vertical walls in the Plan window. If you want to use non-perpendicular walls in your 
contour, in other words, set control points in arbitrary positions on the Workspace, hold down the 
Ctrl key when moving the mouse pointer. 
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2. For convenience and added accuracy you can utilize the Background image, Point grid, and the 
Snap to Grid feature when building the walls of your rooms. If necessary, magnify and scroll the 
contour of your rooms in the Plan window using the Navigation bars controls.  

Moving Walls  

Plan Editor provides various means for editing and modifying contours of rooms. In the Moving walls 
design mode you can move entire wall sections and separate control points.  

To enter the Moving Walls design mode:  

• Choose the Moving walls item from the Edit menu, or  

• Click the button on the Mode bar.  

In the Moving walls design mode you can move entire wall sections only in directions perpendicular to their 
initial positions. As you move the wall sections, their lengths remain constant, while the length of adjacent 
walls changes.  

To move a wall:  

1. Position the mouse pointer over the wall section, in the position you want to change. The 
arrows follow the mouse pointer movement along the wall, indicating the directions in which you 
can move the wall.  

2. Press the left mouse button, and drag the chosen wall. The Status bar at the bottom of the Plan 
Editor window will display two edit boxes, which show the distances between the chosen wall and 
parallel walls, which were nearest to it from both sides, before you start dragging. On the 
Workspace these distances are indicated by red arrows. The appearance of the Status bar and 
the Workspace vary, depending on the current contour of rooms.  

3. Release the mouse button wherever you want to place the wall.  

If you want to specify exact values of distances between the chosen wall and nearest parallel walls, click 
the edit boxes on the Status bar, enter the desired values and press the Enter key on the keyboard.  

Plan Editor gives you wider opportunities of changing the contours of rooms when you move individual 
control points in the Moving Walls design mode. When you move control points, the length of all walls 
originating from these points change.  

To move a control point:  

1. Position the mouse pointer over the control point, which position at the contour you want to change. 

The green arrows displayed on the Workspace, show the directions, where you can move the 
control point.  

2. Press the left mouse button, and drag the control point.  
3. Release the mouse button wherever you want to place the control point.  

By default, you can move control points vertically or horizontally; the walls, coming from them, remain 
perpendicular after the positions of the control points are changed. If you want to move control points in an 
arbitrary direction, press the Ctrl key on the keyboard when you drag them.  
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Notes: 

• Be careful with moving a wall whose adjacent walls contain doorways or window openings.  
• You can move only those walls that were built vertically or horizontally. If you have ever moved a 

control point with holding the Ctrl key on the keyboard, you cannot move walls coming out of this 
control point.  

• If the contour of rooms contains walls with the Main wall status, you will not be able to change the 
length and position of these walls in the Moving walls design mode. Plan Editor will restrict the 
movement of all walls and control points at the contour, which may result in the modification of the 
walls, which have Main wall status.  

• For convenience and added accuracy you can utilize the Background image, Point grid, and Snap 
to Grid options when moving the walls and control point. If necessary, magnify and scroll the 
contour of your rooms in the Plan window using controls on the Navigation bars.  

Main Wall Status  

Main walls in Plan Editor are external or load-bearing walls of rooms, which have fixed positions in rooms. 
You cannot change the position of these walls using the mouse in the Moving walls design mode. Other 
walls in rooms are partition,walls which can be moved by the user when modifying the contour of rooms. 
You can assign and cancel the Main wall status for any of the walls of the contour in the Changing walls 
design mode  

To enter the Changing walls design mode:  

• Choose the Changing walls item from the Edit menu, or  

• Click the button on the Mode bar.  

To assign the Main wall status to a wall:  

1. Click the wall at the contour of rooms that you want to mark as a Main wall. The chosen wall 
becomes red.  

2. Mark the checkbox on the Status bar at the bottom of the Plan Editor window.  

To cancel the Main wall status of a wall:  

1. Click the wall on the Workspace that you want to deprive of the Main wall status. The chosen wall 
becomes red.  

2. Clear the checkbox on the Status bar at the bottom of the Plan Editor window.  

Notes:  

1. You can assign the Main wall status to several walls at the current contour of rooms 
simultaneously. Press the Shift key on the keyboard when choosing the walls.  

2. If necessary, you can modify positions of main walls in the contour by editing the sizes of adjacent 
rooms in the Changing room size design mode.  

Changing the Thickness of Walls  
 
Various walls of your rooms can have different thickness. When you build walls, the default value of 
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thickness is assigned to all of them. If necessary, you can modify this value in the Set defaults dialog 
window. If you have to change the thickness of walls, which have been already built on the Workspace, use 
the Plan Editor commands available in the Changing walls designing mode.  

To enter the Changing walls design mode:  

• Choose the Changing walls item from the Edit menu, or  

• Click the button on the Mode bar.  

To change the thickness of a wall:  

1. Click the wall at the contour of rooms, whose thickness you want to change. This wall becomes red. 

2. Click the edit box on the Status bar at the bottom of the Plan Editor window.  
3. Type in the desired value of thickness in metres, and press the Enter key on the keyboard. 

Notes:  

• Be careful of changes in the size of your rooms when modifying the thickness of internal walls 
(partitions).  

• If you want to specify the same thickness for a few walls at the contour simultaneously, hold down 
the Shift key on the keyboard when choosing them.  

Deleting Walls  

In Plan Editor you can delete walls from your contours in the Changing walls design mode.  

To Enter The Changing Walls Design Mode:  

• Choose the Changing walls item from the Edit menu, or  

• Click the button on the Mode bar.  

To delete a wall:  

1. Click the wall that you want to delete. The wall becomes red.  

2. Click the button on the Status bar at the bottom of the Plan Editor window, or press the 
Delete key on the keyboard.  

 
 
 
 
Notes:  

• If you want to delete a few walls from your contour simultaneously, hold the Shift key on the 
keyboard when choosing them.  
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• It is not possible to delete walls so, that the contour of rooms will consist of two or more 
disconnected parts.  

Resizing Rooms  

Once you have created the contour of rooms, you can modify the size of the rooms. Rooms in Plan Editor 
are the areas on the Workspace, which are fully encircled by walls. To modify the horizontal and vertical (in 
the Plan window) size and the height of your rooms, use the Changing room size design mode of Plan 
Editor.  

To enter the Changing room size design mode:  

• Choose the Changing room size item from the Edit menu, or  

• Click the button on the Mode bar.  

To specify the size of a room:  

1. Click the Workspace inside the room. Lines will be drawn from this point, where you have clicked, 
to the nearest walls in up, down, left and right directions. For rooms rectangular in shape, the lines 
will indicate the length and width of the rooms.  

2. Modify the size of the room in the edit boxes on the Status 
bar at the bottom of the Plan Editor window:  

o Click the left edit box on the Status bar and edit the value of the horizontal size of the room 
in the New room size edit box in the Change room size dialog window. The size of the 
room, which you edit, is indicated by the horizontal line in the Plan window. In the Change 
room size dialog window you can specify how the room will be resized:  
Move the right wall. Check this radio button to move the right wall of the room. 
Move the left wall. Check this radio button to move the left wall of the room. 
Move other control points. Mark this checkbox if you want to move all the walls that are 
bound with the wall that is to be moved. 

o Click the middle edit box on the Status bar and edit the value of the vertical size of the 
room in the New room size edit box in the Change room size dialog window. The size of 
the room, which you edit, is indicated by the vertical line in the Plan window. In the Change 
room size dialog window you can specify how the room will be resized:  
Move the wall displayed below. Check this radio button to move the wall of the room, 
which is displayed below. 
Move the wall displayed at the top. Check this radio button to move the wall of the room, 
which is displayed at the top. 
Move other control points. Mark this checkbox if you want to move all the walls that are 
bound with the wall that is to be moved. 

o To edit the height of the room, click the right edit box on the Status bar and type the 
desired value in it.  

 
Notes:  

• To modify the horizontal and vertical size of all other rooms of the contour in the same proportion as 
you change the size of the chosen room:  
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1. Click the Scale button on the Status bar at the bottom of the Plan Editor window.  
2. Edit the horizontal and vertical size of the room in the Change room size dialog window.  
3. If you want to resize the Workspace proportionally to the change of the contour of rooms, 

mark the Scale workspace checkbox.  
4. Click the OK or Apply buttons.  

• To display information about the current room:  
o Click the Info button on the Status bar at the bottom of the Plan Editor window.  

The Room info dialog window will show the values of the floor area, total area of the walls 
(including doorways and window openings), and factual area of the walls of the room.  

Creating Doorways  

Doorways in Plan Editor are openings (holes) in walls, whose lower bound is at the floor level. When 
decorating 3D scenes in the Outline3D window, you can place doors in these openings. In the Setting 
doorways design mode you can create and modify doorways at the contour of the rooms.  
 
To enter the Setting doorways design mode:  

• Choose the Setting doorways item from the Edit menu, or  

• Click the button on the Mode bar.  

To create a doorway:  

1. Position the mouse pointer over the wall where you want to create a doorway. A symbol follows 
the mouse pointer along the wall helping you to choose a place for a doorway.  

2. Click the wall to set a doorway in it. The doorway symbol becomes red and on the Workspace 
appear four arrow lines, indicating the distances from the doorway bounds to the ends of the wall, 
where it was set, from both sides of the wall.  

To move a doorway:  

1. Position the pointer over the doorway you want to move. The doorway symbol becomes brown; two 
arrows are displayed on the Workspace showing how you can move the doorway along the wall.  

2. Press the left mouse button and drag the chosen doorway. The doorway symbol becomes red. Four 
arrow lines appear on the Workspace indicating the distances from the doorway bounds to the 
ends of the wall, where it was set, from both sides of the wall.  

3. Release the mouse button when its pointer is over the place where you want to set the doorway.  

To change the size of a doorway:  

• Click the doorway, whose height or width you want to edit.  
• Click the edit boxes on the Status bar at the bottom of the Plan Editor window and edit the values 

of the width and the height of the doorway in the left and in the right edit boxes respectively. 
Alternatively click the Edit button on the Status bar. In the Change door parameters dialog 
window edit the values of the doorway width and height. To set the entered values as default, mark 
the Use as default checkbox.  
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For convenience and added accuracy you can utilize the Background image and Point grid, when building 
the walls of your rooms. If necessary, magnify and scroll the contour of your rooms in the Plan window 
using the Navigation bars controls. To delete a doorway:  

1. Click the doorway you want to delete. The doorway symbol becomes red. 

2. Click the button on the Status bar at the bottom of the Plan Editor window, or press the 
Delete key on the keyboard.  

Creating Window Openings  

Window openings in Plan Editor are openings (holes) in walls. When decorating 3D scenes in the Outline3D 
window, you can place windows in these openings. In the Setting window openings design mode you can 
create and modify window openings at the contour of the rooms.  
 
To enter the Setting window openings design mode:  

• Choose the Setting window openings item from the Edit menu, or  

• Click the button on the Mode bar.  

To create a window opening:  

1. Position the mouse pointer over the wall, where you want to set a window opening. A symbol 
follows the mouse pointer along the wall helping you to choose a place for a window opening.  

2. Click the wall to set a window opening in it. The symbol of the window opening becomes red and on 
the Workspace appear four arrow lines, indicating the distances from the doorway bounds to the 
ends of the wall, where it was set, from both sides of the wall.  

To move a window opening:  

1. Position the pointer over the window opening you want to move. The symbol of the window opening 
becomes brown; two arrows are displayed on the Workspace showing how you can move the 
window opening along the wall.  

2. Press the left mouse button and drag the chosen window opening. The symbol of the window 
opening becomes red. Four arrow lines appear on the Workspace indicating the distances from the 
window opening bounds to the ends of the wall, where it was set, from both sides of the wall.  

3. Release the mouse button when its pointer is over the place where you want to set the window 
opening.  

To change the size of a window opening:  

1. Click the window opening, whose size you want to change.  
2. Click the edit boxes on the Status bar at the bottom of the Plan Editor window and edit the values 

of the width, height and sill level of the window opening. 
Alternatively click the Edit button on the Status bar. In the Change window opening parameters 
dialog window edit the values of the window opening width, height and sill level. To set the entered 
values as default, mark the Use as default checkbox.  

To delete a window opening:  
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1. Click the window opening you want to delete. The symbol of the window opening becomes red. 

2. Click the button on the Status bar at the bottom of the Plan Editor window, or press the 
Delete key on the keyboard.  

Scaling Contours of Rooms  

Once you have created the contour of the rooms, you can increase or decrease simultaneously the length 
of all the walls at the contour. To accomplish this task in Plan Editor, use the commands accessible in the 
Scale plan dialog window.  

To invoke the Scale plan dialog window:  

• Choose the Scale item from the Edit menu.  

In the Scale plan dialog window, enter positive scale factor of magnification in horizontal and vertical 
directions in Scale in X and Scale in Y edit boxes respectively. If you want to resize the Workspace in the 
same proportions as the size of the contour, mark the Scale workspace checkbox in the Scale plan dialog 
window. Click the OK button to apply changes and close the dialog window.  

Note: The size of doorways, window openings, thickness of walls, and height of rooms remain unchanged 
when you scale the contour of rooms.  

Changing the Workspace Size  

The Workspace in Plan Editor is a rectangular region of white color displayed in the Plan window. It 
resembles a white sheet of paper, on which the contour of rooms is drawn. You can build and move the 
walls of rooms, doorways and window openings only inside the Workspace. The size of the Workspace is 
by default 30 x 30 metres. The current Workspace size is displayed in the box at the left of the bottom 
Navigation bar. If necessary, you can set and make visible the Background image and the Point grid on the 
Workspace.  

To change the size of the Workspace:  

• Choose the Workspace size item from the Options menu, or  
• Click the box on the Navigation bar, where the current Workspace size is displayed.  

The Workspace size dialog window appears. Enter the desired size of the Workspace in the horizontal and 
vertical directions in the edit boxes in this dialog window. Click the OK button to apply changes and close 
the dialog window.  

You can use an additional option, which is available in the Workspace size dialog window, to resize the 
current contour of rooms proportionally to the change of the Workspace size.  

To change the contour of rooms proportionally to the Workspace modification:  

• Mark the Scale plan checkbox.  

You can also determine the position of the contour in the Workspace when it is resized.  

To specify the position of the contour on the Workspace:  
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• Click the corresponding square on the panel:  

 

Each square symbolizes the position of a plan on the Workspace.  

Notes:  

• The thickness of walls, height of rooms and size of doorways and window openings will remain 
unchanged after the Workspace size changes. 

• You can modify the size of the Workspace along with resizing the contour of rooms using the Scale 
plan dialog window.  

Using the Point Grid  

The Point grid in Plan Editor is a set of points evenly spaced in vertical and horizontal directions, on the 
Workspace. When creating the contour of rooms, the Point grid helps to determine coordinates of various 
points on the Workspace. The Point grid can be made visible or hidden, according to your current needs.  

To display the Point grid:  

• Сhoose the Point grid item from the View menu, or  

• Click the button on the Tool bar.  

 

To hide the Point grid:  

• Choose the Point grid item from the View menu, or  

• Click the button on the Tool bar.  

You can activate the Snap to grid feature, which enables you to add control points on the Workspace at 
the grid intersection points only. Also, you can move walls and control points in fixed steps, corresponding 
to the grid spacing. This feature increases accuracy and alleviates creating contours of rooms with the use 
of the mouse.  

To activate the Snap to grid feature (when it is off):  

• Choose the Snap to grid item from the View menu, or  

• Click the button on the Tool bar.  

To deactivate the Snap to grid feature (when it is on):  
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• Choose the Snap to grid item from the View menu, or  

• Click the button on the Tool bar.  

 

Making 3D Scenes  

Whenever you work in the Plan Editor window, you can make a 3D model on the basis of the current 
contour of rooms and open it in a 3D scene in the Outline3D window.  

To make a 3D model of rooms:  

• Choose the Make 3D scene item from the File menu, or  

• Click the button on the Tool bar.  

As soon as Plan Editor creates the 3D model, the focus is transferred to the Outline3D window, where a 3D 
scene, containing the 3D model is opened.  

Note: If the contour of rooms has been created incorrectly (contains inconsistencies, errors, etc.), this 
command will be ignored. 
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The Outline3D Window 
Using Panels and Toolbars  

The principal element of the Outline3D window is the 3D View window, where the current 3D scene is 
displayed. For manipulating the 3D scene, outputting information about it, and invoking other actions, 
Outline3D utilizes various interface elements, which are located on the Main toolbar, and on the Interior, 
View, Object and Information panels. The content of the panels and their presence in the Outline3D 
window depends upon the current user's actions.  

Main toolbar 

 

This horizontal toolbar is located at the top of the 3D View window and contains nine buttons. Click these 
buttons to activate the basic commands available in the Outline3D window.  

- Invokes the Load scene dialog window. Having chosen a 3D scene, previously saved in 
the Outline3D format (*.o3d), you can open it in the 3D View window.  

- Invokes the Save Your Scene dialog window. This window enables you to save the 
current 3D scene in the Outline3D format (*.o3d).  

- Saves the current 3D scene in a VRML file on your local disk.  

- Reverses the previous action in the 3D window.  

- Reverses the action of the Undo command.  

- Saves a photo of your 3D scene.  

- Activates the Plan Editor window and opens the contour of rooms of the current 3D scene in it. If this 
window does not exist, launches Plan Editor in a new instance of Internet Explorer.  

- Opens the Specification window, which displays information about objects in the current 3D scene.  

- Opens the present Outline3D help file.  

Interior panel 

This panel contains three pages. You can open the desired page by clicking the corresponding button at the 
Outline3D Main toolbar.  
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- From this page you can add eleven special Shapers objects to the current 3D scene. The 
shape of these objects can be modified. 

- Using interface elements on this page, you can select one of standard colors or customize 
your own color, and apply the specified color to various surfaces in the current 3D scene.  

- This page contains a library of 3D objects (furniture, home appliances, etc.), which you can 
add to the current 3D scene, and covers, which can be applied to various surfaces in the scene.  

View panel 

 

This panel contains various interface elements, which are destined for choosing the navigation mode and 
moving the camera in the 3D View window.  

 

Object panel 

 

Outline3D invokes Object panel when you are in the Edit mode and modify a 3D object, chosen in the 3D 
View window.  

Information panel 

 

The Information panel shows information about the 3D object or cover, which you have chosen in the 
Outline3D Resource galleries or 3D View window.  
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Loading and Saving 3D Scenes  

Outline3D allows you to save your 3D scenes locally in the Outline3D proprietary format (*.o3d file 
extension) and to open them later for further editing. You can also save your completed scenes in the 
VRML format (*.wrl file extension).  

To open an existing 3D scene:  

1. Click the button on the Main toolbar at the top of the Outline3D window. The 
Load Your Scene window appears.  

2. Choose a file from the list of available files in *.o3d format.  
3. Click the Open button.  

To save a 3D scene locally:  

1. Click the button on the Main toolbar at the top of the Outline3D window. The 
Save Your Scene window appears.  

2. Enter the file name.  
3. Click the Save button. The scene will be saved in the Outline3D proprietary format (*.o3d file 

extension).  

To save a 3D scene in a VRML file:  

1. Click the button on the Main toolbar at the top of the Outline3D window. The 
Save Your VRML file window appears.  

2. Enter the file name.  
3. Click the Save button. The scene will be saved in the VRML format (*.wrl file extension).  

Notes:  

1. Outline3D does not open or import 3D scenes in the VRML format. In other words, you cannot 
continue editing those 3D scenes which have been exported in the VRML format, unless they had 
been saved also as *.o3d files.  

2. All the textures used in a 3D scene are saved in a separate folder. The name of the folder is formed 
by the name of the scene and "res_" prefix.  

3. The 3D scenes in the VRML file format can be viewed by any standard VRML browser such as 
Cortona (R) VRML Client from ParallelGraphics.  

For more information about the ParallelGraphics Cortona VRML Client, please visit:  

http://www.parallelgraphics.com/products/cortona.  

 

Making Photo  

In the Outline3D you can make a photo of a 3D scene, which is opened in the 3D window. Outline3d saves 
images of 3D scenes in *.BMP, *.JPG, and *.PNG files. When saving a photo, you can specify the picture 
size in the Select Image Size dialog.  
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To make a photo of your rooms:  

1. Click the button on the main toolbar. The Save Frame dialog window will appear.  
2. Enter the file name in the Save Frame dialog window. The supported formats are: *.BMP, *.JPG, 

*.PNG.  
3. In the Select Image Size dialog choose the desired picture size, and click OK.  

Navigation in the 3D View Window  

Moving in 3D scenes is similar to moving a camera in the real world. Think of a video camera that captures 
images in the real world and converts them into electronic signals for viewing on a screen. Your movements 
in the world continually position and orient the camera. The screen in Outline3D, on which you can see the 
image taken by the camera, is the 3D View window.  

In Outline3D you can select one of three available navigation modes:  

• Front view  
• Top view  
• Isometric view  

Interface elements for switching between different navigation modes and moving in 3D scenes are placed 
on the View panel at the bottom of the Outline3D window. This panel also contains the 2D Plan window, 
which shows the contour of rooms and can be used for navigation in 3D scenes. In addition to these 
elements, you can also use the mouse and keyboard for navigating in 3D scenes. The available navigation 
commands and contents of the View panel vary, depending on the current navigation mode.  

 

Navigation in the Front view navigation mode.  

This mode is activated by default, when you start working in the Outline3D window. A highlighted button 
at the View panel indicates that the Front view navigation mode is currently active.  

• To select the Front view navigation mode:  

o Click the button on the View panel. 
• To move around 3D scenes using a mouse:  

1. Click anywhere in the 3D View window.  
2. Move the mouse while holding down its left button. The direction in which you drag the 

mouse determines the camera motion.  
3. Release the left mouse button to stop moving.  

3. To move around a 3D scene using keyboard:  
1. Make sure that the 3D View window is in focus (the keyboard navigation is only accessible 

in this case). If not, click anywhere in the 3D View window to activate it.  
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2. Press and hold the corresponding arrow keys on the keyboard to move in the desired 
direction. These keys have the same functions as the mouse movements.  

4. Moving in the 3D scene using the View panel:  
o Click the button to rise.  
o Click the button to descend.  
o Click button, or press the "3" key on the keyboard to turn upwards.  
o Click the buttons, or press the "4" key on the keyboard to turn downwards.  

• To change the field of view in 3D scene:  
o Shift the red slider on the Field of view slider control to the left to increase the current field 

of view and to the right to decrease it.  

 

• Using the 2D Plan window.  
• The 2D Plan window displays the walls, doorways and window openings of the current 3D scene. 

The bottom vertex of the blue triangle in the window shows the current position of the camera in the 
3D scene. To zoom in this window, shift the slider and click the buttons on the zoom bar on the right 
of this window. You can use this window both for viewing the plan of the rooms and for navigating in 
3D scenes.  

•  
o To move in the 3D scene:  

� click anywhere in the 2D Plan window, where you would like to move the camera 
to 

o To change the viewing direction:  
� right-click anywhere in the 2D Plan window to specify a point, where you want to 

turn the camera to 
o To change the viewing direction gradually:  

1. Place the mouse pointer over the current position of the camera in the 2D Plan 
window, so that it will display a blue circle in the window.  

2. Press the left mouse button and drag the mouse to adjust the viewing direction.  
3. Release the mouse button to stop changing the viewing direction.  

Navigation in the Top view navigation mode.  

In the Top view navigation mode, you can move the camera in 3D scene in the horizontal plane: to the left 
and to the right and forward and backward. In addition, you can zoom in and out in the 3D View window 
that is undistinguishable from moving up and down in the 3D scene. You can use this navigation mode for 
viewing 3D scenes from above, this view resembles a two dimensional plan. 

• To select the Top view navigation mode:  

o click the button on the View panel.  

In the Top view navigation mode, you can use the keyboard and interface elements on the View 
panel to navigate in the 3D scene.  
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• To move around 3D scenes using keyboard:  
1. Make sure that the 3D View window is in focus (the keyboard navigation is only accessible 

in this case). Otherwise, click anywhere in the 3D View window to activate it.  
2. Press and hold the arrow keys on the keyboard or click corresponding buttons on the View 

panel to move to left, right, forward and backward in the 3D scene.  
• To zoom in and out in the 3D window:  

o To zoom in, click the button on the View panel or press the "+" key on the keyboard.  
o To zoom out, click the button on the View panel or press the "-" key on the keyboard.  

Navigation in the Isometric view navigation mode.  

Isometric view navigation mode provides you four fixed viewpoints for viewing 3D scenes. The positions of 
the viewpoints correspond to the corners of a rectangular region, which bounds the 3D scene. In this mode 
you cannot change the positions and viewing directions of the viewpoints. The Isometric view navigation 
mode may help you to preview 3D scenes.  

• To select the Isometric view navigation mode:  

o click the button on the View panel.  

 

Using Doors and Windows  

Doors and windows in Outline3D are three-dimensional interactive objects; you can open or close them 
when navigating in 3D scenes.  

To open or close doors and windows in a 3D scene:  

• click them in the 3D View window.  

3D models of doors and windows are stored in the Outline3D Resource galleries in the Doors and 
Windows categories correspondingly. When a 3D scene is opened in the 3D View window, you can attach 
doors and windows from these categories to doorways and window openings in the scene.  

To open the Doors or Windows categories in the Outline3D Resource galleries:  

1. Click the button on the Main toolbar of the Outline3D window. The list of the 
categories in the Outline3D Resource galleries appears.  
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2. Click the Doors or Windows items in the list to open the corresponding categories.  

To attach a door or a window to an opening in a 3D scene:  

1. Click items in the list of the categories to select the desired category of doors or windows.  

 

2. Drag the icon of the door or window from the Outline3D Resource galleries to the 3D View window 
using the mouse.  

3. Release the mouse button over the wall in the vicinity of the doorway or window opening, or just 
inside the corresponding opening.  

Once you have added doors and windows to 3D scenes, you can edit them in the Edit mode of the 
Outline3D window. The main particularity of doors and windows as 3D objects in Outline3D is that they are 
firmly linked with the doorways and window openings, where they have been placed. Thus you cannot 
move or scale doors and windows as other 3D objects in Outline3D. To move and resize doors and 
windows, use Plan Editor, where you can modify the position and size of corresponding openings.  

To enter the Edit mode:  

• Double-click the door or window that you want to edit, in the 3D View window.  

The Object panel appears below the 3D View window:  
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The Object panel contains four icons, which show positions of hinges in the opening. Another three icons 
on the panel indicate how the door or window is placed in the opening: in the middle or outside from one or 
another side of the wall.  

To specify how a door or window should be placed in an opening:  

• Click icons on the Object panel to set the desired appearance of the selected door or window.  

To delete the chosen door or window:  

• Click the Delete button on the Object panel.  

To exit the Edit mode:  

• Click the Close button on the Object panel.  

Using 3D Objects  
 
When a 3D scene is opened in the 3D View window, you can add to it different 3D objects from the 
Outline3D Resource galleries. The Outline3D Resource galleries are a hierarchical structure, which 
contain 100’s of objects. You can drag-and-drop objects into 3D scenes from the galleries. 

You can also use your own 3D objects that you have created, and saved in a VRML file before. 

To open the Outline3D Resource galleries:  

• Click the button on the Main toolbar of the Outline3D window. The list of the 
categories in the Outline3D Resource galleries appears.  
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To add a 3D object to a 3D scene:  

1. Click items in the categories list to select the desired category in the Outline3D Resource galleries.  

 

2. Choose the desired item in the Outline3D Resource galleries and drag its icon to the 3D View 
window.  

3. Release the mouse button when its pointer is over the position in the 3D scene where you want to 
place the 3D object.  

For quick searching and locating items in the Outline3D Resource galleries, you can sort them in 
categories. Use the list box at the bottom of the Interior panel to select whether the items in the categories 
will be sorted by their type, or by the name of their manufacturers.  

 

To place your own object into the scene:  

1. Choose a VRML file with your object.  
2. Drag-and-drop the file to the desired place into the opened 3D scene.  

Once you have added 3D objects to the scene, you can manipulate and edit them in the Edit mode of the 
Outline3D window.  

Selecting Objects  

To manipulate an object you should select it in the 3D View window. You can do the following actions: move 
object, rotate object, delete object, change the object's orientation, scale object, and modify a group of 
parametric objects if they have common parameters. Selecting enters the Edit mode and allows you to then 
make changes.  

Selecting in the 3D View window:  

• To select an object, right-click or double-click it. White borders appear around the selected objects 
in the 3D View window. Please note, that double-clicking is an obsolete command and it cannot be 
used together with the modifier keys Ctrl, Alt and Shift  

• To select multiple objects, right-click the object one by one with the Shift key pressed or use the 
selection tool  

• To cancel the selection, click Close on the Object panel  
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Using the Selection Tool  

1. Place the mouse at the corner of the rectangular area in which you want to select objects  
2. Right-click and drag the mouse until the selection is the size you want. As the mouse moves, a line 

appears to indicate the border of the selection  
3. Release the mouse button. All objects whose at least one vertex is inside the box appear selected.  

 

White borders appear around the selected objects in the 3D View window. 
 

 

Modifiers keys  

Use one of the selection commands and press the modifiers key:  

• Shift - to add the object to the group of selected object  
• Alt - to cancel the selection in the group  
• Ctrl - to reverse the selection  

Note: When selecting objects there are no differences between doors, windows and objects from other 
Outline3D Resource galleries. You can select objects, doors, and windows the same way.  

Operations with selected objects  

In the editing mode the Object panel appears below the 3D View window:  

 

MOVE: When selected, activates moving manipulation mode for the selected object or group of objects. 
You can move the object by dragging it in the 3D View window, setting the numerical values on the Object 
panel that specify translations in the X, Y, and Z directions, in metres, or use the slider thumb to set a new 
translation.  
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Note. You can move the object in a chosen direction. To move an object along Z-axis, move it with the Ctrl 
key pressed. To move an object along X-axis, or Y-axis, move it with the Shift key pressed.  

ROTATE: When selected, activates rotating manipulation mode for the selected object or group of objects. 
You can rotate the object by rotating it with the mouse in the 3D View window, setting the numerical values 
on the Object panel that specify rotation in the X, Y, and Z directions, in metres, or use the scroller to set a 
new rotation.  

SCALE: When selected, activates scaling manipulation mode for the selected object. This operation is 
available only when a single object is selected.  

To change the scale of the object proportionally in all directions, shift the slider on the Object panel. Click 
the X, Y, or Z buttons, and then type the desired values into the edit-boxed, to change the corresponding 
sizes of the chosen object or group of objects. Then click the Scale button again or press the Enter key on 
the keyboard.  

DELETE: deletes the selected object or a group of objects  

CLOSE: exits the edit mode for all selected objects  

Changing the orientation of an object: any 3D object has six predefined orientations on the surface, on 
which it was placed when you added it to a 3D scene. The default orientation of an object is when it is 
positioned "normally" on this surface, in other words, its lower part touches the surface, regardless of how 
this surface is oriented itself. Predefined orientations are shown at the icons on the Object panel as two 
cubes, where the small cube shows the position of the upper part of the object.  

To change the orientation of the chosen 3D object or a group of objects, click one of the icons at the right 
part of the Object panel:  

 

Aligning objects: When several objects are selected, you can align them and move them to one of the four 
corners of the bounding box that includes selected objects. But this operation is only possible if all of the 
selected objects have the same orientation, that is, the directions of their coordinate axes X, Y, and Z are 
congruent. 

To align the selected objects, click one of the arrow icons at the upper right part of the Object panel:  

 

Using the Information Panel  

The Information panel shows information about the 3D object or cover, which you have chosen in the 
Outline3D Resource galleries or 3D View window. If you have chosen a group of objects in the 3D View 
window, the Information panel displays the information about each object of the selected group.  

In the edit mode the Information panel appears below the 3D View window near the Object panel:  
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Interface elements of the Information panel  

Button Tooltip Purpose 
  Marks an object for deselecting or deleting 

 
Fit To Object Fits the camera to the object 

 
Deselect Object Deselects the object 

 
More Info Shows more information about the object 

 
Synchronize Synchronizes the object: opens the corresponding category in 

the Outline3D resource galleries 

 

Deselect checked objects Deselects the marked object or group of objects 

 

Delete checked objects Deletes the marked object or group of objects 

Using parametric objects  

Outline3D offers you a possibility to use special parametric objects. Any user can change the appearance of 
these objects in the Outline3D window. You can change color and shape of parametric objects. When you 
are in the object-editing mode, the parameters tab of the info panel represents possible samples of the 
object's appearance. 

To change the appearance of a parametric object:  

1. Enter the Edit mode, by double-clicking the object. The parameters tab of the info panel will display 
all possible samples of the object's appearance.  

 

2. Choose the desired sample.  
3. Exit the Edit mode, by clicking the close button.  
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Editing object materials  

You can edit materials (textures and colors) on those surfaces of 3D rooms and 3D objects, where it is 
possible to drag a cover from the Outline3D resource galleries. Editing objects' materials is the same as 
editing materials on the walls, floor and ceiling of the rooms.  

Object Collision  

The Outline3D application supports object-to-object collision detection. Object-to-object collision detection 
in a three-dimensional scene is a procedure of determining whether a given shape, if it were to undergo 
some transformation (for example, to be moved, rotated, or scaled), would encounter an obstacle in the 
form of another shape.  

This allows you to put the object right against the wall or together with another object. As a result you can 
now easily and quickly place furniture items one by one alongside a wall or another line, a feature that is 
quite important in arranging the details of a kitchen.  

By default, collision detection is switched on.  

To switch off/on the collision detection option:  

1. Enter the edit mode, by clicking the object with the right mouse button, or double-clicking the object  
2. Clear/mark the collision detection check-mark on the object panel to switch off/on the collision 

detection option  

 

3. Quit the edit mode, by clicking the close button  

Note. Collision detection does not work at the time, when you drag-and-drop an object into a scene, or 
transform it. So the object may cut into an obstacle, and you will not be able to move it. To move the object, 
switch the collision detection off, move the object, and then switch the collision detection on again, to 
position your object more exactly. 

Using Coloring  

Using the Coloring page on the Interior panel you can specify the color of various surfaces in 3D scenes, 
including floor, walls and ceiling of the rooms. Colors can be applied also to the surfaces of Shapers 
objects in 3D scenes. It is possible to choose one of standard colors or set your own color, defining its RGB 
component values and emissive component.  

To open the Coloring page:  

• Click the button on the Main toolbar at the top of the Outline3D window.  
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To specify a color using the Coloring page:  

• Click color palettes, which contain 8 and 64 colors, respectively, to select a standard color, or  

 

• Shift sliders to define the RGB components and the emissive component of your own color.  

 

The sample box at the top of the Coloring page will display the currently specified color.  

 

To apply the specified color to a surface in a 3D scene:  

1. Drag the specified color from the sample box into the 3D View window.  
2. Release the mouse button, when its pointer is over the surface in the 3D scene, which you want to 

color.  

 

Using Covers  

Covers in Outline3D are graphic images (textures)that you can apply to various surfaces in 3D scenes. 
Covers in Outline3D are stored in the Outline3D Resource galleries.  

You can also use your own covers (textures). The following graphic formats are supported: JPG, PNG, GIF.  

To open the covers categories in the Outline3D Resource galleries:  

1. Click the button on the Main toolbar of the Outline3D window. The list of the 
categories in the Outline3D Resource galleries appears.  
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2. Click the Finishing materials item in the list to open the cover categories.  

To apply a cover to a surface in a 3D scene:  

1. Click items in the list of the categories to select the desired category of covers.  

 

2. Choose the desired cover item in the Outline3D Resource galleries and drag its icon to the 3D 
View window.  

3. Release the mouse button when its pointer is over the surface in the 3D scene which you want to 
apply this cover.  

To place your own texture into the scene:  

1. Choose a file with your texture (*.jpg, *.png, *.gif).  
2. Drag-and-drop the file to the desired surface in the opened 3D scene.  

Editing Materials and Eyedropper Function  

You can edit materials (textures and colors) for those surfaces of rooms and objects, where it is possible to 
drag a cover from the Outline3D resource galleries. Editing objects' materials is similar to editing materials 
on other surfaces in the scene: walls, floor and ceiling.  

To change the appearance of a texture:  

1. Enter the Edit mode, by right-clicking the texture that you want to modify with the Ctrl and Alt keys 
pressed.  
The Edit Texture panel appears below the 3D View window:  
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2. Modify the texture.  
o x-size: specifies how to scale the texture on the face in X (horizontal) direction. 0.5 means 

that the picture is compressed by 2 and repeated twice in the horizontal  
o y-size: specifies how to scale the texture on the face in Y (vertical) direction. 0.5 means 

that the picture is compressed by 2 and repeated twice in the vertical  
o x-shift: moves the texture in X (horizontal) direction of the texture coordinate system  
o y-shift: moves the texture in Y (vertical) direction of the texture coordinate system  
o rotation: changes the rotation angle of the cover  
o self-illuminated: mark this check-mark, to model covers that emit their own light  

Note. To set one of the x-size, y-size, x-shift, y-shift or rotation values, type the desired value in the 
corresponding textbox or use the slider.  

Because the texture coordinates, not the texture, are transformed, the moving direction appears 
reversed when viewed on the surface of geometry.  

3. Quit the Edit mode, by clicking the Close button.  

Using Eyedropper function and changing colors  

Selecting a color on a 3D object, or on any surfaces in a 3D scene acts as the Eyedropper function. You 
can display the color of the selected object on the Coloring page. You can also use the color sample in the 
scene again by dragging its sample box from the Information panel onto the desired surface in the scene.  

To enter the Edit mode for a color:  

• right-click the color that you want to modify with the Ctrl and Alt keys pressed 

 

Using Shapers Objects  
 
In Outline3D you can add eleven special Shapers objects to 3D scenes from the Shapers page on the 
Interior panel. These objects give you virtually boundless opportunities to customize the appearance of 3D 
scenes. Basically, Shapers objects are flat surfaces, which allow flexible modification of their shapes and 
appearances in 3D scenes. The description of Super cover, Additional wallpaper, Wall cover, Super 
doorway, Special stairs, Spiral staircase, Super stairs, Super pipe, Ground, Clouds, and Super picture 
Shapers objects is given on the Shapers page below the corresponding icons.  
 
Super cover. A flat surface with an arbitrary contour that you can place on any surface in a 3D scene. A set of 
vertices, connected with lines, forms the bounds of a contour. In the Edit mode, you can change a Super cover by 
moving vertices or adding new vertices to a contour. To remove an excessive vertex from a contour, drag it to any 
adjacent point. 
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Additional wallpaper. This gives flat constant surfaces of an equal height along room walls. Use this feature to 
create multiple colors or coverings on the walls from floor to ceiling. 
 
Wall cover. A flat surface that you can place on any wall in a 3D scene. Drag and drop the Wall object onto a wall, 
and then drag and drop a cover to this wall. Use this shaper if you want to apply different covers on different walls in 
your rooms. 
 
Super doorway.  An opening which may have an arbitrary form. Drag and drop it close to a doorway or window 
opening in a 3D scene. Editing Super openings is similar to editing Super covers. 
 
Special stairs. A special object for creating stairs with the desired number of steps, step height, step depth, and step 
width. Drag and drop the Special stairs into a 3D scene. In the edit mode you can change the stairs parameters, by 
typing the desired values in the corresponding edit boxes. 
 
Spiral staircase. A special object for building spiral staircases. Drag and drop the Spiral staircase into a 3D scene. In 
the edit mode you can change the staircase parameters, by typing the desired values in the corresponding edit boxes. 
You can change step height, number of steps, radius, step width, and angle. 
 
Super stairs. A series of three steps. You can use Super stairs to create the right number of steps in your stairway. 
Editing Super stairs is similar to editing Super covers. Click the red button below this object to make the height and 
length of the individual steps equal. 
 
Super pipe. A special object to be used for utility systems such as plumbing.. Drag and drop the Super pipe into a 3D 
scene. In the edit mode you can change the form of the pipe section, set the section sizes, and set the connecting 
points of the pipe axis in the rooms.  
 
Ground. This shaper allows you to create a ground area around your 3D house. To add a Ground, drag and drop its 
icon on any part of your 3D rooms. Then you can drag-and-drop the textures (lawns, stones, bricks, etc.) on it or add 
trees, furniture items and other outdoor structures from the Outline3D catalog. 
 
Clouds. This shaper allows you to create a sky with moving clouds in your 3D scene. To add Clouds, drag and drop its 
icon into the scene. 
 
Super picture. A rectangular surface that you can use as a mat for placing a picture from the Decorative elements > 
Paintings folder of the Outline3D Resource gallery. 

To open the Shapers page on the Interior panel:  

• Click the button on the Main toolbar at the top of the Outline3D window. 

To add a Shapers object to a 3D scene:  

1. Choose the desired Shapers object on the Shapers page and drag its icon to the 3D View window.  
2. Release the mouse button when its pointer is over the position in the 3D scene which you want to 

place the Shapers object.  

Note: Additional wallpaper and Super opening can have only certain positions in 3D scenes, at the 
walls and in existing openings in scenes, respectively.  

Once Shapers objects are added to 3D scenes, you can apply colors and covers to their surfaces. When 
you resize Shapers objects, the texture mapping changes accordingly, except for Super picture Shapers 
objects.  

You can manipulate and edit Shapers objects in 3D scenes in the Edit mode of the Outline3D window. If 
necessary, you can delete Shapers objects from 3D scenes.  
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To enter the Edit mode:  

• Double-click the Shapers object, which you want to edit, in the 3D View window.  

White borders appear around the chosen Shapers object in the 3D View window. The Object panel is 
shown below the 3D View window. Note that the appearance of the Object panel will vary, depending on 
the Shapers object that you have chosen.  

To move the chosen Shapers object:  

1. Click the Move button on the Object panel.  
2. Position the mouse pointer over the chosen Shapers object in the 3D View window. The mouse 

icon changes to .  
3. Press the left mouse button and drag the Shapers object to a new place in the 3D scene. 

Alternatively, enter the new position of the Shapers object in the coordinates of the scene directly in 
the edit boxes on the Object panel and press the Enter key on the keyboard. Or, click X, Y or Z box 
on the panel to select the axis, and shift the slider to move the Shapers object along this axis in the 
3D scene.  

To rotate the chosen Shapers object:  

1. Click the Rotate button on the Object panel.  
2. Position the mouse pointer over the chosen Shapers object in the 3D View window. The mouse 

icon changes to .  
3. Press the left mouse button and move its pointer to rotate the Shapers object in the 3D scene. 

Alternatively, enter the values of rotation of the Shapers object in its local coordinates directly in the 
edit boxes on the Object panel and press the Enter key on the keyboard. Or, click X, Y or Z box on 
the panel to select the axis, and shift the slider to rotate the Shapers object along this axis.  

To scale the chosen Shapers object:  

1. Click the Scale button on the Object panel.  
2. Enter the desired values of the scale along the X, Y and Z axis in the edit boxes on the Object 

panel.  
3. Click the Scale button again, or press the Enter key on the keyboard.  

To resize the Shapers object proportionally in all directions, shift the slider on the Object panel.  

To change the shape of the chosen Shapers object:  

1. Click the Edit button on the Object panel.  
2. Click the bound of the Shapers object, where you want to add a new vertex.  
3. Drag vertices at the bound of the Shapers object with the use of the mouse to resize it.  

Notes:  

o You can modify the shape of Super cover, Super opening and Super stairs Shapers 
objects.  

o To delete a vertex at the bound of a Shapers object, drag and drop it at an adjacent vertex.  
o To level the height and length of the footsteps of the Super stairs, click the red cube below 

this Shapers object.  

 39 



The Outline3D Window 

To delete the chosen Shapers object from the 3D scene:  

• Click the Delete button on the Object panel.  

To exit the Edit mode:  

• Click the Close button on the Object panel.  

 

Getting Specification  

Anytime you work in the Outline3D window, you can view the extended specification of the current 3D 
scene. The extended specification of the current 3D scene includes the following information about the 
interior of rooms:  

• A 2D plan of the rooms with the contours of 3D objects added to the scene.  
• The floor and wall areas and ceiling height in the rooms.  
• Linear sizes of rooms (only for rectangular rooms).  
• Placements of doors and windows on the plan, their sizes and quantity.  
• A detailed list of 3D-objects (for example, furniture), placed in the interior.  

The Specification window displays a table, containing the following information about the 3D objects and 
materials, which have been added to the current scene:  

• The photo (graphic image) of an object or a material.  
• The model of an object or a material.  
• The name of the manufacturer of an object or a material. 
• The Web link.  
• The catalog number of an object or a material.  
• The dimensions of an object (Width x Depth x Height).  
• The price of an object or a material.  
• The number of objects of the same type or space (in square meters) covered with a material.  

To invoke the Specification window:  

• Click the button on Main toolbar at the top of the Outline3D window.  

To display the preview of the Specification window:  

• Choose the Print preview item from the File menu of the Specification window.  

To print the contents of the Specification window:  

1. Choose the Print item from the File menu of the Specification window.  
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2. Specify the options of your printer and click the OK button. 
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